[ERROR] [EPAgent] jetty start fail
search cancel

[ERROR] [EPAgent] jetty start fail

book

Article ID: 136514

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE

Issue/Introduction

Siteminder Agent Metrics are not showing 


EPAgent log contains:



[ERROR] [EPAgent] jetty start fail

java.net.BindException:

Address already in use

     

  at sun.nio.ch.Net.bind0(Native Method)

     

  at sun.nio.ch.Net.bind(Net.java:460)


Environment

Release : 13.2

Component : APM Agents

Cause

port numbers are not configured correctly 

Resolution

resolved after updating port details in IntroscopeEPAgent.properties and IntroscopeCAPIConfig.xml


1- stop EPAgent and siteminder webagent. 

2- modify EPAgent profile (make backup copy before change) 


introscope.epagent.config.networkDataPort= ####

introscope.epagent.config.httpServerPort= ####


Make sure that the above two ports are not in use on the system. 


3- modify IntroscopeCAPIConfig.xml on APM-SS0 side ((make backup copy before change)



name="epagent_httpServerPort" value="####"

name="epagent_networkDataPort" value="####" 


4- start siteminder webagent. and EPAgent