Failed to update properties on the Jaspersoft server
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Failed to update properties on the Jaspersoft server

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Article ID: 136511

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Reports integrated with Clarity is not working and when you run the command admin update jasperParameters command  you are getting the error below

"Failed to update :jasper parameters :failed to update properties on the Jaspersoft server and getting exception like Clarityjasper admin:unauthorized access

Environment

Release :Any

Cause

This error is due to incorrect configuration for user  in CSA under reporting tab where user was changed

Resolution

1. Stop the clarity service

2. Delete the existing keystore 

3. Start the nsa and beacon service from one server

4. Update the user in CSA-Reporting tab to ppmjasperadmin

5. Delete the keystore from report server 

6. Generate the keystore and copy to report server. More documentation can be found in this link

7. Login to Jaspersoft using superuser 

8. Go to user under your organization and search for jasperadmin

9. Edit the user jasperadmin and delete all the profile attribute except domainWhitelist as it is read only

10. Run the command admin update jasperParameters and it will generate the profile attribute for user ppmjasperadmin

12. Run the sync commands admin jaspersoft syncPPMContext -userName superuser -password XXX and you should be able to run the reports again.