CA Business Intelligence / Jasperserver-pro won't start in tomcat
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CA Business Intelligence / Jasperserver-pro won't start in tomcat

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Article ID: 136503

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

After installation of Jasper server, when starting the Tomcat https server, the Jasper application does not start and the catalina log shows the error:

ERROR ContextLoader,localhost-startStop-1:331 - Context initialization failed 
java.lang.RuntimeException: KeystoreManager.init was never called or there are errors instantiating an instance. 

Environment

CA BUSINESS INTELLIGENCE 6.3

Cause

The files .jrsks and .jrsksp were located in a folder not accessible to the tomcat server.

Also , the home user available in the tomcat configure was pointing to a location not available to the system account running the service.

Resolution

Check what user is starting the Tomcat server. (in services). Usually it is the system account.

Open the Tomcat configure tool (All Program > Apache Tomcat > Configure Tomcat). Click on the Java tab.

Make sure that the additional option of "-Duser.home=" exists and is pointing to the home folder of the user running the Tomcat service (in system account it is %Windows%\system32\config\systemprofile )

Make sure that folder also contains the  .jrsks and .jrsksp files.