Forgot Password link in the New UI does not update cmn_sec_users.last_pwd_change column
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Forgot Password link in the New UI does not update cmn_sec_users.last_pwd_change column

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Article ID: 136484

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The user can use the Forgot Password link, resets their password but when they try to login with the new password it is not recognised and error "Error during login API-1030 : Error during login. Password is expired or needs to be reset" is displayed.  Resetting the password via the Forgot Password link in the New UI does not update cmn_sec_users.last_pwd_change column


STEPS TO REPRODUCE
1. Go into System Options and change the value on "Number Of Days Until Password Expires" to 1 (This is to simulate a scenario where genuine password expiry happens in Production systems)
2. Pick a user from the DB whose last_pwd_change (in cmn_sec_users table) is more than 2 days in the past. If there is no such user, update this column to a value more than 2 days in the past. Change this account's email address to your own email address.
3. Go to the New UI's login screen
4. Click on Forgot Password link. Provide the username of the user from step 2.
5. Wait for the Forgot Password email. once it is received, click on the link, and reset password
6. Go back into the New UI's login screen and try to login

Expected Results: Should be possible to login since the password has been reset
Actual Results: Logging into the system is still not possible. New UI throws API-1030 error.

Environment

CA PPM 15.x

Cause

This issue is caused by the Defect DE48385


Resolution

The defect DE48385 is resolved in version 15.6.1 of CA PPM.

Additional Information

Noticed that the last_pwd_change column on cmn_sec_users does not get updated through the Forgot Password process. This column however, is reset to date and time at which passwords are changed when done from the Classic UI.