Wrong target in agent receiver.log
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Wrong target in agent receiver.log

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Article ID: 136470

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Updated On:

Products

CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE - Scheduler (dSeries) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation AE - Business Agents (AutoSys)

Issue/Introduction

I install a database plugin and define a test job. The job remains as Ready. I find the error below in the agent receiver.log:

 

 

XX/XX/XXXX 00:00:12.345+0200 1 TCP/IP Controller Plugin.Receiver pool thread <Regular:1>.CybReceiverChannel.a[:214] - Can't parse the message: cybermation.library.communications.CybConversationWrongMessageException: Wrong target:

                                                                                                                      cybermation.library.communications.CybConversationWrongMessageException: Wrong target

   

Environment

Release : 12.1

Component : CA WORKLOAD AUTOMATION DE (DSERIES)

Release : 11.4

Component : CA WORKLOAD AUTOMATION AGENT FOR DATABASES (DBAGT)

Cause

The Workload Automation DE manager can communicate with the agent but unable to parse message to the alias agent due to invalid communication alias name definition for the Database plugin in the agent's agentparm.txt file. 

Resolution

The _n suffix for the 'communication.alias_n' parameter in agent's agentparm.txt file must start from 1 since only one alias agent is configured and defined in the agentparm.txt file.


Edit the agent's agentparm.txt file and update the parameter; 

Change 

communication.alias_6=<agent alias name>

to 

communication.alias_1=<agent alias name>


where <agent alias name> is the alias name for the agent.


You need to restart the agent for the change to take effect.