Wrong target in agent receiver.log
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Wrong target in agent receiver.log

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Article ID: 136470

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Updated On:

Products

CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE - System Agent (dSeries) CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation AE - Business Agents (AutoSys) Workload Automation Agent

Issue/Introduction

After installing database plugin a test job remains as Ready. Following error may be seen in the agent receiver.log:

XX/XX/XXXX 00:00:12.345+0200 1 TCP/IP Controller Plugin.Receiver pool thread <Regular:1>.CybReceiverChannel.a[:214] - Can't parse the message: cybermation.library.communications.CybConversationWrongMessageException: Wrong target:
                                                          cybermation.library.communications.CybConversationWrongMessageException: Wrong target

Environment

Component : CA WORKLOAD AUTOMATION AGENT

Cause

The Workload Automation DE manager can communicate with the agent but unable to parse message either due to an invalid agent name or agent alias name in the agent's agentparm.txt file. 

Resolution

  • The agent name is defined by the agentname parameter in the agentparm.txt and must match the definition on the manager.
  • For DE, each of the plugins that are installed on the agent will have an alias defined in the agentparm.txt file, which would be noted as communication.alias_n
    Note:
    The _n suffix for the 'communication.alias_n' parameter must be consecutive starting with 1.

    Example:
                 communication.alias_1=AGENT_PS
                 communication.alias_2=AGENT_SAP
                 communication.alias_3-AGENT_DB

Remember that any time you make changes to agentparm.txt, you must restart the agent for changes to take effect.