Reporting Link not seen in CSA with installation of Clarity 15.7
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Reporting Link not seen in CSA with installation of Clarity 15.7

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Article ID: 136459

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Reporting Link not seen in CSA with installation of Clarity 15.7

 

Steps to reproduce:

  1. Install Clarity 15.7 or upgrade to 15.7 without Jaspersoft integration with Clarity
  2. Login to CSA and observe the Reporting Link is not  available 

 

  

   Expected Results: Reporting link should be available 

   Actual Results: Reporting link is missing

Environment

Release: 15.7.0

Cause

This is a defect DE50849 

Resolution

This is a defect DE50849  fixed in 15.7 Patch 1

 

Workaround:

  1. Stop all the clarity services 
  2. Login to the server and go under Clarity_HOME\bin
  3. Locate the properties.xml and keep a backup 
  4. Edit the properties.xml and locate the reportServer tag 
  5. Modify the webUrl in the reportserver from http://<my_reportserver>/reportservice to http://<my_reportserver/reportservice
  6. Example:  <reportServer id="jaspersoft" webUrl="http://&lt;my_reportserver/reportservice" context="/reportservice" home="" serviceUrl="http://localhost:8000" volumeName="" username="ppmjasperadmin" vendor="jaspersoft" databaseId="Niku" jndiName="jdbc/clarity" dwJndiName="jdbc/dwh" orgName="" orgId=""/>
  7. Start the Clarity NSA and Beacon Service
  8. Login to Clarity CSA and now you should be able to see the Reporting link