Unable to rediscover Cisco nexus device 7700 in snmpcollector
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Unable to rediscover Cisco nexus device 7700 in snmpcollector

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Article ID: 136282

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Unable to rediscover and poll Cisco nexus device 7700 in snmpcollector

This issue can also be encountered wih other network devices discovered using SNMPv3 with snmpcollector (intermittently).



Environment

Component : UIM - SNMPCOLLECTOR

snmpcollector 3.43 HF7

Cause

After network device reboot for any reason unable to readd device in snmpcollector.

Profile shows failed discovery in snmpcollector gui.

Can see below error in snmpcollector logs even though the snmpv3 credentials are checked and are valid.

Jul 20 07:13:46:752 [DiscoveryController3, snmpcollector] DeviceDiscovery failed: xxxxxx.com.sg in state Discovery Failed. Reason: Credentials Invalid or device is unreachable.  Unable to communicate with device using given credentials

 

Resolution

Observed with network device discovered with snmpv3 protocol and monitored with snmpcollector probe.

Workaround which is option 1 is to delete the device, restart snmpcollector probe and rediscover the device

 

Option1
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  1. delete the device from snmp-collector gui and save 
  2. deactivate the snmp-collector probe
  3. active the probe 
  4. add the device (Query from discovery server option in snmpcollector GUI to Import, or just create a new profile with the Device via IP or Hostname

 Option2
======== 

Upgrade snmpcollector probe to version 3.50 or greater and rediscover the device.

 

Additional Information