xFlow or Search Server product uninstall and re-install issue
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xFlow or Search Server product uninstall and re-install issue

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Article ID: 136260

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Due to some issues ,  we uninstalled xFlow and Search Server  on a machine .  After that ,  we tried to re-install xFlow and Search Server  via SM 17.2 installer on this same box ,    SM installer always listed xFlow and Search Server products as  (Update)  instead of  as   brand new fresh install on this machine somehow .  It caused us not  able to get xFlow and Search Server products reinstalled successfully on this machine any more  even though we already cleared all the xFlow and Search Server related entries with this specific machine in  al_cdb_componentinstallstate   and  al_cdb_configurationparameters  tables in MDB   


See attached screensnhot :



Environment

Release : 17.2

Component : SERVICE DESK MANAGER

Cause

SM installer doesn't only check al_cdb_componentinstallstate   and  al_cdb_configurationparameters  tables in MDB  to get to know  specific information about Service Managnement products installation in an Service Management environment  , but also checks analystUI.ini  file    ( for xFlow )  and  searchServerUI.ini file   ( for Search Server )  under C:\Windows\   on a specific machine to determine if that specific machine has corresponding product installation or not .   


Sometimes due to permission issue or improper   uninstalling product issue ,    xFlow or Search Server product is not actually uninstalled completely ,      analystUI.ini  file  and  searchServerUI.ini file  are not cleaned accordingly by uninstall process .    For example ,   when analystUI.ini  file  and  searchServerUI.ini file  are remained on that specific machine and kept with xflow and Search Server previous installation   information  ,   bot the xFlow  and Search Server's previous installation home folders on that machine are already gone or removed/renamed by you .  In this scenario ,   when SM installer is invoked,  it is able to read the information analystUI.ini  file  and  searchServerUI.ini file  on that machine , found the corresponding previous   xFlow and Search Server's installation information  but it can find corresponding installation home folder ,   therefore ,  SM installer is misled to "think"  that you are attempting to update previous   xFlow and Search Server  installation .  

Resolution

If you are sure that you want to re-install a brand new xFlow or Search Server on that same machine  ,   you will need to make sure :


1)  all related xFlow or Search Server entries with that specific machine are cleared/removed in al_cdb_componentinstallstate   and  al_cdb_configurationparameters  tables in MDB  


2)  on that machine ,   under C:\Windows\ folder ,    analystUI.ini  file    ( for xFlow )  or    searchServerUI.ini file   ( for Search Server )  are removed  also .  


With 1) and 2)  ,  when you invoke SM installer ,  it should be able to consider xFlow   or Search Server as brand new re-install  on that machine .