DevTest Portal showing -Error while retrieving list of Projects. (500 No JSON Formated Retrofit Error)
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DevTest Portal showing -Error while retrieving list of Projects. (500 No JSON Formated Retrofit Error)

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Article ID: 136257

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Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

Have a DevTest installation on a Linux box and the license key was updated today.

All services are up and running, but upon login to the portal, a web page error is displayed. 

 


Error while retrieving list of Projects. (500 No JSON Formated Retrofit Error <html> <head> <meta http-equiv="Content-Type" content="text/html;charset=utf-8"/> <title>Error 500 Server Error</title> </head> <body><h2>HTTP ERROR 500</h2> <p>Problem accessing /res-hub/v1/projects. Reason: <pre> Server Error</pre></p><h3>Caused by:</h3><pre>java.lang.RuntimeException: java.lang.NullPointerException at com.ca.devtest.acl.servlet.filters.RemoteAuthenticationFilter.doFilter(RemoteAuthenticationFilter.java:285) at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1676) at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:101) at org.eclipse.jetty.servlet.

 

Environment

All supported DevTest releases.

Cause

The Portal was caching a file location that no longer existed under LISA_HOME\Projects

The Portal was looking for LISA_HOME\Projects\res-hub\v1\projects

That no longer existed.

Resolution

1) When we logged into the portal as admin, would get an error 500 Problem accessing /res-hub/v1/projects. Reason:

2) This problem started when added a new license back on 10-19-2020

3) Stopped the Portal and other services.

4) Delete the lisatmp folder to clear logs and all cache information.

5) Moved the 2 additional renamed license files to a backup directory in the LISA_HOME folder

6) Started the Portal and other services and noticed there is still an error.

7) When on the physical server for the Portal looked at the LISA_HOME\Projects folder> Did not see a folder called /res-hub

8) Went back to the Portal and did a refresh on the projects list and then logged out and back in.

9)  No longer were getting the error.

10)  Tested this with both IE and EDGE and saw no further errors.

It looks like the Portal had cached the project path for a folder that was no longer valid on the file system.

Once we refreshed the list and changed it to an existing project, no longer saw the error.