Service Catalog startup error - Exception while trying to start JMS broker java.io.IOException: Detected missing/corrupt journal files. 21806 messages affected.
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Service Catalog startup error - Exception while trying to start JMS broker java.io.IOException: Detected missing/corrupt journal files. 21806 messages affected.

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Article ID: 136131

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Service Catalog Services do not start.


There are these messages in the view.log.


2019/08/21 14.53.58.267 ERROR [localhost-startStop-1] [BrokerService] Failed to start Apache ActiveMQ ([brkr-999991DDACFB4AC7B2F3AB48D17FA595, null], java.io.IOException: Detected missing/corrupt journal files. 21806 messages affected.)


2019/08/21 14.53.59.205 ERROR [localhost-startStop-1] [ActiveMqBroker] Exception while trying to start JMS broker

java.io.IOException: Detected missing/corrupt journal files. 21806 messages affected.

at org.apache.activemq.store.kahadb.MessageDatabase.recoverIndex(MessageDatabase.java:854)

Environment

Release : 17.1

Component : CA SERVICE CATALOG

Cause

Root cause investigation not complete.

This knowledge document is provided as partial information to help with troubleshooting any similar cases. 

Please advise any findings to Broadcom Support.



Resolution

These steps enabled Service Catalog to START.

They did NOT clear all "corrupt" messages.

1) Go to the folder USM_HOME/view/bin/activemq-data/<ID of the JMS broker>/kahadb


The JMS broker ID was as per the view.log messages of "brkr-999991DDACFB4AC7B2F3AB48D17FA595." There was only ONE folder in this activemeq-data location.


2) Renamed the kahadb folder to "kahadb_old."


3) Restarted Service Catalog Service.



Additionally, some minor performance tuning was done as per the Additional Information links.

Additional Information

Performance Tuning Parameters for Service Catalog


High usage of java.exe process at Service Catalog server when integrated to Service Desk Manager