Registry service has stopped and shows 'Couldn't connect to IAM' eventhough IAM is running
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Registry service has stopped and shows 'Couldn't connect to IAM' eventhough IAM is running

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Article ID: 136078

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Updated On:

Products

CA Application Test Service Virtualization

Issue/Introduction

After restarting all DevTest services at the same time including the 'DevTest Identity Access Manager Service' (IAM), sometimes the Registry service fails to start with 'Couldn't connect to IAM'.

But IAM has started and is running.

This may also happen if the DevTest services are configured as automatic and the machine is rebooted.

A manual restart of the Registry service resolves the problem but if the reboot is unattended, then the stopped Registry may go unnoticed.


Environment

All supported DevTest releases.

Cause

On some installations, the Registry service starts more quickly than IAM.

Resolution

Configure the Registry service to restart after one or two failures.

In Windows services right click the DevTest Registry service and select properties.

In the Recovery tab configure:

First failure: Restart the Service

Second failure: Restart the Service

Reset fail count after: 1 days

Restart service after: 1 minutes

Click OK