Maintenance schedules are removed in Spectrum due to Spectrum Gateway Probe
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Maintenance schedules are removed in Spectrum due to Spectrum Gateway Probe

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Article ID: 136056

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Updated On:

Products

CA eHealth CA Spectrum

Issue/Introduction

The Spectrum gateway probe has been upgraded to 8.67 hf 1 or greater and the maintenance_mode probe to 8.53 (or above) to resolve the issue with the maintenance probe synchronization.  However it has been noticed that the maintenance schedules have been removed, and/or cpu and memory are constantly increasing in the SpectroSERVER process.


To determine if this issue affects you, in the Spectrum Locater, run the Schedules - All Schedules search.

In the Search Results, review the Name of the Schedule.  If the name of the schedule is over 100 characters, this issue affects you.  The character limit does not include the description of the schedule which is in parenthesis.


For example, this schedule name is over 100 characters:



Every week on Sun, Mon, Tue, Wed, Thu, Fri and Sat  from 11:39 AM for 23 hours 59 min, starting Oct 20, 2018 (This is for monthly testing)
 

This schedule name is not over 100 characters as the description in the quotes does not count:


Every week Mon thru Fri from 12:00 AM - 2:00 AM (This is a test that is run daily to allow interface updates during the night)

Environment

Release : 10.3

Component : Spectrum Core / SpectroSERVER

Cause

The maintenance schedule table in the UIM database only supports 100 characters.  If there are any schedule models in Spectrum with more than 100 characters, this causes synchronization issues between UIM and Spectrum schedules.

Resolution

Destroy the Schedule Model in Spectrum that has over 100 characters and recreate it so that the name does not contain more than 100 characters.


Then run through the following process:


1. Stop spectrumgtw probe

2. Stop maintenance_mode probe

3. Stop all wasp probes (that run USM, not WASP that runs AC)

4. Run the following queries on the UIM database:

   a. TRUNCATE TABLE MAINTENANCE_WINDOW;

   b. TRUNCATE TABLE MAINTENANCE_SCHEDULE_MEMBERS;

   c. DELETE FROM MAINTENANCE_SCHEDULE;

   d. TRUNCATE TABLE MAINTENANCE_SCHEDULE;

5. Delete the SpectrumScheduleCache and UIMScheduleCache from the spectrumgtw probe cache folder

6. At this point, you can start maintenance_mode probe, and wasp again

7. Clean up any long name schedules in Spectrum

8. Reenable the spectrumgtw probe, and Spectrum will sync its schedules to UIM


Additional Information

On the Spectrum side, if you review the mysql events, you may see there are thousands of events per day for model destroy and create on Schedules:


 

Event : Dist Model: Master Created - User SVC-local-UIMIntegration@<SS Name> created master model Once on Jul 21st, 2019 from 5:45 AM for 6 hours 15 min (0x1df64e0) of type Schedule.


0x10a01 - Dist Model: Master Created - User {S 5} created master model {S 3} ({H 1}) of type {S 4}.

0x10a03 - Dist Model: Master Destroyed - User {S 5} destroyed master model {S 3} ({H 1}) of type {S 4}.

0x10202 - A model has been destroyed. The model was {m} of type {t} destroyed by {u}.

0x10201 - A model has been created. The model is {m} of type {t} created by {u}.