CA WA SQL Agent jobs fail with error java.lang.NoClassDefFoundError
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CA WA SQL Agent jobs fail with error java.lang.NoClassDefFoundError

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Article ID: 136012

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Updated On:

Products

Workload Automation Agent

Issue/Introduction

The mssql_call.bat script fails to complete and results in this error.

 java.lang.NoClassDefFoundError:       cybermation/library/afm/CybInvalidAFMException

@at   Error: A JNI error has occurred, please check your installation and try again Exception in thread "main" 

Environment

Release:  11.4 and above


Component:  CA Workload Automation Agent for Informatica

Cause

The error is due to security libraries.  The mssql_call.bat scripts needs to load new libraries to be able to authenticate and run the job.

Resolution

Check the following files:

 

<Agent_install>/jars/ext/bcprov-ext-jdk15on.jar

<Agent_install>/jars/ext/security/bcprov-ext-jdk15on.jar

 

If the above files are missing, then make sure the System Agent and Informatica plugin are at  version 11.4.1.  If the system agent is at 11.4, then upgrade to 11.4.1.

 

Next, edit the mssql_call.bat. 

 

Change the following in CLASSPATH.

   Replace this:

 

   %LIBS%\ext\jsafeJCEFIPS.jar

 

    with this:

 

   %LIBS%\ext\security\bcprov-ext-jdk15on.jar;%LIBS%\ext\bc-fips.jar

 

Restart the agent.

Note: Remove "jsafeJCEFIPS.jar" from the Agent directory.  Do not rename, the file must be removed.
Add the BC files (bcprov-ext-jdk15on.jar, bc-fips.jar
) in the ext\security directory.  They can be downloaded from the BC site.

 

Test your job again or run the mssql_call.bat from cmd prompt.