WA DE Web Client does not run REST API commands
search cancel

WA DE Web Client does not run REST API commands

book

Article ID: 136002

calendar_today

Updated On:

Products

ESP dSeries Workload Automation ESP dSeries Workload Automation - Scheduler (dSeries)

Issue/Introduction

The Web Client and Java process are running, but it's not responding to REST API calls.

Environment

Workload Automation DE Web Client

Cause

There could be several reasons;

  • The Web Client port (e.g. 8443) is blocked. If the port is not known, then look for the "Connector port" string in <install_dir>/apache-tomcat/conf/server.xml file.

Example:

Connector port="8443" protocol="HTTP/1.1"

  • Improper permissions on the directories of the Web client.

Resolution

Take the following steps to ensure REST API functionality with the Web client:

  • Firewall/Network Configuration: Open the Web client's designated listening port for REST API calls (default: 8443). This port must allow incoming requests from all outside clients.
  • Initial Web Client Login: Perform a one-time login to the Web client using your web browser. This critical step enables the REST calls to identify and connect to the appropriate DE server.
  • Permissions: Check the permissions of the Web Client directories.