DevTest Registry not able to connect to Enterprise Dashboard using Derby
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DevTest Registry not able to connect to Enterprise Dashboard using Derby

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Article ID: 135983

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Updated On:

Products

Service Virtualization

Issue/Introduction

Unable to start Registry.

Environment

All supported DevTest releases.

Cause

The Enterprise Dashboard (EDB) had gone down with a memory error. 

Resolution

Although the Enterprise Dashboard (EDB) showed running, it was hung, so needed to delete the process.

Updated the EnterpriseDashboardService.vmoption file with this entry:

-Xmx2048m

 

Since the EDB was connected to Derby and have been running on Derby for quite some time so renamed the dradis.db to something else to start with a fresh EDB database.

Derby is only supported for out of the box verification, an enterprise database should be used for the EDB. 

Started the EDB and was able to see it from the browser.

Registry was then able to connect