Hub renamed, but old name still listed in IM and Admin Console
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Hub renamed, but old name still listed in IM and Admin Console

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Article ID: 135964

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We renamed a hub.  All the robots in the hub are correctly identified with the new hub name, but in IM and Admin console, the robots were  still listed under both names.  Customer removed the old name from Name Services and from the hubs list, but it kept reappearing under the hubs list. What do we need to do to clean out the old name?

Environment

  • Release: 8.5 or higher
  • Component: UIM - INFRASTRUCTURE MANAGER

Cause

- hub data artifacts, sync delay

Resolution

Customer unchecked all the boxes on the Name Services tabs of all hubs (and clicked Apply). Then removed the old hubs from each Hubs tab.  

But before the customer was finished with them all, they started to propagate again so he rechecked the rest of the boxes in Name Services.  After he checked back after some time, the old names were gone.

Apparently, it took more time than expected but the hubs did sync up and the old hub names were eradicated.

Additional Information

If a hub keeps reappearing in the Infrastructure Manager (IM):

  1. Shutdown the 'reappearing' hub's robot service.

  2. Rename the hubs.sds file on every hub and restart them.

  3. Then go into the other hub GUIs and select the Hubs tab. Find the hub, then right-click and remove it.

  4. Make sure any Name Services entries for that hub are removed.

  5. Leave the hub-robot service shutdown for at least 15 minutes. This should allow the other hubs / hub 'lists' to repropagate. 

  6. Finally, if after 15 minutes the hub remains gone and does not reappear, then start the hub's robot service up again.