DX IM UIM xendesktop probe not collecting desktop metrics
search cancel

DX IM UIM xendesktop probe not collecting desktop metrics

book

Article ID: 135880

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Metrics in question are the ones the metrics page shows this note for and the log shows value=null for them. 

Aug 07 14:31:41:395 [BulkSender Monitor, xendesktop] Sent NimQoS QOS_XENDESKTOP_DESKTOP_CPU D, source=xxxx,target=NOSESSION::NOIPADDRESS, measuretime=1565202700404, value=null,


For example:

QOS_XENDESKTOP_DESKTOP_CPU CPU usage of the desktop

Note: The default value for QOS is NULL when no monitor type is present in the XenDesktop server. 

Environment

Release : 9.0.2

Component : UIM - XENDESKTOP

Cause

The probe collects these metrics only for those desktops in an active state which is obtained via the PowerState and SummaryState settings in Citrix. 

PowerState = On 

SummaryState = InUse


The values the probe obtains can be seen in the file desktops.xml found at:

$\Nimsoft\probes\application\xendesktop\data_{profile_name}


Example:

<Property Name="DNSName" Type="System.String">desktop 1 name</Property>

<Property Name="PowerState" Type="Citrix.Broker.Admin.SDK.PowerState">Unknown</Property>

<Property Name="SummaryState" Type="Citrix.Broker.Admin.SDK.DesktopSummaryState">Unregistered</Property>

It's metrics will not be monitored


<Property Name="DNSName" Type="System.String">desktop 2 name</Property>

<Property Name="PowerState" Type="Citrix.Broker.Admin.SDK.PowerState">On</Property>

<Property Name="SummaryState" Type="Citrix.Broker.Admin.SDK.DesktopSummaryState">InUse</Property>

It's metrics will be monitored


Resolution

It is up to the Citrix admin to make these settings. 

If guidance is needed on how to make these settings check with Citrix support.