Identity Portal Health Check monitoring
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Identity Portal Health Check monitoring

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Article ID: 135807

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Updated On:

Products

CA Identity Governance CA Identity Portal CA Identity Suite CA Identity Manager

Issue/Introduction

How can I check the status of the Identity Portal?  My IP monitor shows "Available: false" even though my Identity Portal is up and running.

Environment

Release : 14.3

Component : Identity Portal standalone

Cause

System Availability (available) - Indicates whether an end user can log in to CA Identity Portal. The value of the available parameter is true when all of the following statements hold true: 

  • A main connector is configured in the Admin UI console.
  • The main connector started successfully and at least one User Attribute for this connector is configured. For more information about User Attributes configuration, see Managed Objects Attributes
If one of these statements does not hold true, the result of this parameter is false.  

Resolution

CA Identity Portal 14.4 Monitoring Documentation

Confirm the IP login comes up and you can login.

If so, monitor should display "showPortalLoginPage: true"

Confirm two criteria are being met for "available: true":

1. Do you have a main connector? if not, go to Admin UI and configure one and make sure it is "UP"

2. On the left side select "Managed Object Attributes"

 




If no attributes listed, add one: Managed Objects Attributes

Example: Added a First Name |USER_ID|


Go back and retest the REST call, it should now return 'available = true'

http://host:8080/sigma/rest/public/available

{"available":true,"showPortalLoginPage":true,"version":521"}

 

Additional Information

Identity Portal Monitoring:

CA Identity Portal 14.4 Monitoring Documentation


Managed Object Attributes

CA Portal 14.4 Managed Objects Attributes