sdgtw probe creating separate incidents for each alarm raised from a single profile in the net_connect probe
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sdgtw probe creating separate incidents for each alarm raised from a single profile in the net_connect probe

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Article ID: 135709

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe

Issue/Introduction

An auto operator profile in the nas will auto assign any red critical alarm to the user that triggers the creation of an incident in ServiceNow through the sdgtw probe.


The sdgtw probe is configured to auto update and auto acknowledge Incidents in ServiceNow. 


It seems in all other cases, once an Incident is created for a UIM alarm, as the count goes up the single Incident is updates as expected. 


However, there was an occurrence where a device monitored by the net_connect was shut down and the ping alarms for this device became red critical.  At this point, the sdgtw probe created a new Incident for this one alarm every 2 minutes (the monitoring interval configured in the net_connect profile monitoring this device).


The sdgtw probe created a new incident for every alarm from this net_connect profile instead of updating the existing incident.

Environment

Release : 9.0.2

Component : UIM - SDGTW v2,1 but valid for any release of the probe

Cause

Two nas Auto Operator profiles were defined which assigned the problematic alarm to 2 different users.

Resolution

The sdgtw probe is designed to handle a single alarm_assign message for any alarm that needs to have an incident created in ServiceNow.


When 2 different Auto Operator (AO) Profiles are active and assign different users to the same alarm, this causes the nas to keep issuing new alarm_assign messages, one for each AO Profile for the same message.  The sdgtw probe will then create a new incident in ServiceNow each time it receives a new alarm_assign message which contains the configured UIM user name in the assigned_to field of the alarm_assign message. 


The only way to prevent creating multiple incidents in ServiceNow for the same alarm is to make sure that no 2 AO Profiles in the nas assign a user to the same UIM alarm.