Connection request rejected. Connection limit of 256 exceeded.
search cancel

Connection request rejected. Connection limit of 256 exceeded.

book

Article ID: 135665

calendar_today

Updated On:

Products

SITEMINDER

Issue/Introduction

The SiteMinder Web Agents started to throw 500 Agent API errors, and no one could log in. A review of the SMPS.log shows the following error;


Connection request rejected. Connection limit of 256 exceeded.


A restart of the Policy Server resolved the issue for a period of time, then the issue resurfaced.



Environment

Release : All Versions

Component : SITEMINDER -POLICY SERVER

Cause

The Policy Server by default is configured with a 'Max Connection Limit' of 256 connections. This sets the maximum number of concurrent Agent connections that are allowed by the Policy Server. If this limit is reached, the Policy server will refuse any additional agent connections, and the error messages will be logged.

Resolution

Customer's Policy server was only configured with the default 256 Max Connection Limit in the SMConsole, and this limit was hit. Customer needs to tune the environment to handle the expected load. To resolve this issue, increase the 'Max Connection Limit' in the SMConsole to a value appropriate for the load in your environment.