No response from remote server RegistryClient
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No response from remote server RegistryClient

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Article ID: 135611

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Updated On:

Products

Service Virtualization

Issue/Introduction

Just upgraded DevTest.

Started Portal and getting this error in the portal-grails-res-hub.log:

 

INFO com.itko.lisa.net.ClientBase - No response from remote server RegistryClient [an=tcp://somehostname:2010/Registry]

 

Environment

All supported DevTest releases.

Cause

Portal not resolving localhost to the actualhostname

Resolution

Copied file {{DEVTEST_HOME}}/_phoenix.properties to phoenix.properties.


Edited file phoenix.properties and made these changes:


Uncomment line #registry.host=localhost, changed localhost to actualhostname

Uncomment line #reshub.hostname=localhost, changed localhost to actualhotname


Start Portal service and was able to connect to Registry.


Additional Information

If you happen to be using SSL and get this message:

INFO com.itko.lisa.net.ClientBase - No response from remote server RegistryClient [sn=ssl://somehostname:2010/Registry]

 

Add this property to the local.properties file:

https.protocols=TLSv1.2

Restart the Registry and Portal Services.

 

NOTE: Starting with DevTest 10.7.0 the above property is already defined in the lisa.properties file.