Azure probe - Unable to connect to the requested subscription
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Azure probe - Unable to connect to the requested subscription

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Article ID: 135330

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

When configuring the Azure probe in admin console, and click on Actions -> "Verify Selection", the following message can be displayed:




In the probe logs (loglevel 5), we can see similar logs as the ones below:


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Jul 22 14:33:36:181 INFO [Data Collector - <resource_name>, azure] GenInventory.update() for resource: <resource_name>

Jul 22 14:33:36:181 INFO [Data Collector - <resource_name>, azure] PERF: START: azure inventory update for <resource_name>

Jul 22 14:33:41:224 ERROR [Connection tester - 0, azure] Requested id was xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, got [] 

Jul 22 14:33:41:224 FATAL [Connection tester - 0, azure] Failed to connect to <resource_name> 

Jul 22 14:33:41:224 FATAL [Connection tester - 0, azure] (1) error, Connection failed for resource [<resource_name>].: Requested subscription (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx) not found 

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In the Azure environment, we can see that the related subscription is active:



Additionally, the Application ID, as well the Directory (Tenant ID) are also configured accordingly.


Environment

Azure Probe 3.14

Cause

This can happen if some required role ( like "contributor")  is missing in the Application configuration at the Azure side.

Resolution

You need to configure the Application roles accordingly at Azure side. If the problem remains, please contact the Broadcom Support team.