Inbound Filtering option - Provision_Account - is missing.
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Inbound Filtering option - Provision_Account - is missing.

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Article ID: 135250

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

Inbound synchronization keeps CA Identity Manager users up-to-date with changes that occur in the Provisioning Directory. Changes in the Provisioning Directory occur when Provisioning Server performs provisioning actions on an endpoint, and stores the corresponding notifications in the Provisioning Directory. Provisioning Server pushes the inbound notifications to the CA Identity Manager.


CA Identity Manager receives inbound notifications from the Provisioning Server based on the filters that you configure.


For more information on Inbound Notification configuration please refer to the CA Identity Manager Product Documentation, link below:


https://docops.ca.com/ca-identity-manager/14-3/EN/administrating/inbound-notifications-configuration


The filters are hard coded and it has been noted that one filter is missing "Provision_Account" 


In the following scenario, the provisioning server generates a notification (example below)


20190705:124635:TID=002a3c:CreateAcct:C180:C178:F: FAILURE: Child CreateAcct (eTADSDirectoryName=DL_Test)
20190705:124635:TID=002a3c:CreateAcct:C180:C178:F:     rc:  0x0013 (Constraint violation)
20190705:124635:TID=002a3c:CreateAcct:C180:C178:F:     msg: :ETA_E_0083<MAC>, Account for Global User 'T22226' on Active Directory 
20190705:124635:TID=002a3c:CreateAcct:C180:C178:F:+Endpoint 'DL_Test' update failed: Account already exists, but is associ
20190705:124635:TID=002a3c:CreateAcct:C180:C178:F:+ated to another Global User


Because the "Provision_Account" filter is missing, as soon as you filter on something, you do not get any notifications associated with the error above. Consequently you do not have any relevant information in the vst (View Submitted Tasks).

Environment

Release : 14.1

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

This is a coding issue.

Resolution

CA Identity Manager Engineering has released a 14.1 GA (General Availability) fix for this issue (HF-DE424201.zip) and it is available upon request from CA Broadcom Technical Support.  This fix will be included int he next CP (Cumulative Patch).