Service Point search results are not related to what the user is searching for
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Service Point search results are not related to what the user is searching for

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Article ID: 135002

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

SearchMS (Service Point) results not related to what end user is searching for.

On this example, the end users is searching for "contrato", but if you take a look at the returned results, they have more than the Categories related to the search itself.

See below:


Environment

Release: 17.2 / 17.2 RU1

Component: Service Point

Cause

It happens because the SearchMS also goes through ticket description when performing a search.

Because of that, if the word you are searching for is part of a ticket description, the category related to this ticket will appear as a result. 

Resolution

1) Go to C:\Program Files\CA\xFlow\APPS\Services\searchmicroservice-17.0.479\conf;

2) Open application.conf;

3) Go to line 770 (17.2) or 777 (17.2 RU1);

4) Replace from:

sdmSearchFields = ["ctg_name^8","ctg_name.asis^8","ctg_description^4","ctg_description.asis^4","inc_desc^2"],

To:

sdmSearchFields = ["ctg_name^8","ctg_name.asis^8","ctg_description^4","ctg_description.asis^4"],

5) Save;

6) Restart XFlow.

Now it works as expected (see below):


Attachments