REST API inconsistent return on CP's during healthcheck.
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REST API inconsistent return on CP's during healthcheck.

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Article ID: 135000

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When using the REST API to monitor the health of the system (GET /<client id>/health), the status of the Communication Processes (CP's) returned would be inconsistent. This would often report CP's as down, even though they were up and active within the system. This appears to have always reported a lower number of active CP's, and all other processes returned expected results.

Environment

Release : 12.2.0 - 12.2.3

Component : AUTOMATION ENGINE

Cause

The timing for checking the activity of the CP's was long enough it was possible for a request on status to return a different result then the actual status within the system. This has been modified to increase the window for polling internally.

Resolution

This issue was found and fixed within Automation Engine.


Fix-Description:

REST API system/health endpoint reports wrong number of running CPs


An issue has been solved where the REST API endpoint /ae/api/v1/0000/system/health/ returned a number of CPs that was sometimes smaller than the actual number.

Numbers of other server process types were correct.


This is fixed in:

Automation Engine 12.3.0

Automation.Engine 12.2.4