Impersonation issue on agent running on HP UX
search cancel

Impersonation issue on agent running on HP UX

book

Article ID: 134973

calendar_today

Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

While installing an agent on the HP-UX server the below mentioned problems are faced during execution of action "Run Command line" and "RUN Command line" with impersonation.


  1. Unable to establish SSH session/channel java.net.ConnectException
  2. Impersonation error, Verify the user running Nolio agent has privileges to impersonate other users.

Environment

Release Automation - All versions

Cause

The HP-UX have some specific OS level configuration you need to have in order to execute the action "RUN command line" in impersonated mode please find solution below for specific problem listed above.


Troubleshooting steps

  1. Locate wrapper.log file in NolioAgetInstallDir/logs
  2. Please find various scenarios and analysis tips (The agent uses ActionsRunner.sh file for remote ssh)
               2.1 In wrapper.log you can find entry like, which reflect that the impersonateduser have an issue in cd to NolioAgetInstallDir.

                         ERROR:

                             0m/home/impersonateduser~ cd "/CARA/CA/ReleaseAutomationAgent" 

                             INFO   | jvm 1    | 2019/09/11 16:08:53.697 | ksh: /CARA/CA/ReleaseAutomationAgent: permission denied

                         VALIDATION:

                            Login to system as impersonateduser

                            Check the present working directory it should be same as shown in logs i.e. /home/impersonateduser

                            Try to run the command cd "/CARA/CA/ReleaseAutomationAgent" . You will get same error i.e. permission denied

                         CORRECTION:

                            The impersonateduser is not having correct permission on NolioAgetInstallDir. Please run solution 2 command 2

Resolution

Problem 1 solution:

  1. Stop the agent service
  2. Edit file processes.properties file in the /conf. Change the port number from 22 to 1122 (The ssh on HP-UX ideally runs on 1122 port). example: ssh.port=1122
  3. Save the file processes.properties
  4. Clean the data from persistency/ files_cache/ and files_temp directory inside NolioAgentInstallDir
  5. Check the user with which you are running SSH action for example testuser is part of group owning NolioAgetInstallDir. It can be verified by command #groups testuser 
  6. Start the agent service
  7. Check the agent is online an ASAP
  8. Run the remote SSH action

Problem 2 solution:

  1. Stop the agent
  2. Verify if you are able to run the command ssh [email protected] -p 1122
  3. chmod 755 -R NolioAgentInstallDir
  4. Uncomment the line in ActionsRunner.sh that has: cd "${0%/*}"
  5. Increase process.timeout and server.timeout (in processes.properties) to 160000
  6. Start the agent


Additional Information

For slow execution of impersonated actions:


ISSUE (KNOW HP-UX ISSUE) :The newer version of the ssh daemon (/usr/bin/sshd) will read the entire file /var/adm/wtmps if it exists. Since this file grows without bound, it can become exceeding large and cause delays in the login process. 

SOLUTION: Please locate /var/adm/wtmps and inspect it's size. The chances that file might be of a large size. If so, the solution is to purge file or clean its content: Then retest a flow in CA RA