CA Service Catalog configuration to Process Automation fails
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CA Service Catalog configuration to Process Automation fails

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Article ID: 134787

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Catalog integration with ITPAM is failing when I hit the "test" button.

This happens with a login failure in the view.log.

This occurs when my username (defined in the ITPAM SLCM global data set) has a backslash in it.

Normally this occurs if you replace spadmin with a user account which has a domain prefix.

Environment

Release : 17.2

Component : CA SERVICE CATALOG

Cause

This is caused by the backslash not being escaped so that the product removes it.

However this needs to be escaped once for ITPAM to interpret it and once for Catalog to interpret it.

Resolution

Any backslashes in the username need to be escaped twice.

So you need to specify four backslashes like:  \\\\

When ITPAM processes it then it will end up passing \\ to catalog.

Once catalog processes it then \\ will be interpreted as \.