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Clarity PPM Help link is not working after moving from docops.ca.com to techdocs.broadcom.com

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Article ID: 134770

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

STEPS TO REPRODUCE

1. Log in to Clarity and click on the Help Link

Expected Results: Once you click on the link it should open a pop up page with the relevant documentation

Actual Results: Once you click on the link blocks the relevant documentation page 

Environment

Release: Clarity 15.x till 15.7


 

Cause

Since our documentation site has moved from docops.ca.com to techdocs.broadcom.com, you are running into the problem 

Resolution

This issue is fixed in 15.7.1
Workaround

The following command lists option values for the CONTENT_SECURITY_DOMAINS:
admin system-options -list CONTENT_SECURITY_DOMAINS
  1. Navigate to directory where clarity is installed like ${install.dir}/bin directory
  2. Run the following commands: (If possible avoid copy/paste method by typing commands at command line and hit enter after each one.)
  3. admin system-options -delete CONTENT_SECURITY_DOMAINS
  4. admin system-options -add CONTENT_SECURITY_DOMAINS "'self'" -multi
    admin system-options -add CONTENT_SECURITY_DOMAINS app.pendo.io -multi
    admin system-options -add CONTENT_SECURITY_DOMAINS cdn.pendo.io -multi
    admin system-options -add CONTENT_SECURITY_DOMAINS cdnjs.cloudflare.com -multi
    admin system-options -add CONTENT_SECURITY_DOMAINS docops.ca.com -multi
    admin system-options -add CONTENT_SECURITY_DOMAINS fonts.googleapis.com -multi
    admin system-options -add CONTENT_SECURITY_DOMAINS techdocs.broadcom.com -multi
  5. Restart all the services by executing service stop start all 

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