Receiving error message:DC900431 V1 Data Base Error, Module CADSRLSE with an IDMS error code of 1211?
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Receiving error message:DC900431 V1 Data Base Error, Module CADSRLSE with an IDMS error code of 1211?

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Article ID: 13475

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Updated On:

Products

Dispatch Output Mgmt

Issue/Introduction

What do I do if I get this error message:  

DC900431 V1 Data Base Error, Module CADSRLSE  and 

DC900432 V1 Error Status - 1211

Environment

Release: DISPAX00200-11.7-Dispatch
Component:

Cause

CA Dispatch STATUS file is full.

Resolution

The 1211 means that the STATUS file (.RDS) is full or very close to being full. This file contains historical records only. The status records are those that you see when you select option 4 from the main menu.

When the file fills, the method for recovery is to bring CA Dispatch down and execute the DSEXSFIX job out of the CADSJCL library to initialize the .RDS file. The DSEXSFIX job will run in 5 minutes as opposed to trying to run the DSEXPSST or DSEXPURG job to delete the expired entries after the status file is already full. Clients simply don't have a maintenance window large enough for the DSEXPSST or DSEXPURG jobs to run to successful complete and will end up having to CANCEL the job and execute DSEXSFIX anyway.

If the STATUS information is something that you need, you can run the CADSJCL library job DSEXCULP with the 'member' symbolic set to MEMBER=DSCULP06. This will produce a hard copy listing of all of the status information that can be saved and used for reference in case someone needs to see these historical status records. Execution of the DSEXSFIX job deletes all records out of the STATUS file.

As a follow up, you need to keep this STATUS file clean. You should be running a DSEXPSST or DSEXPURG job (PGM=RDBATCH) as part of your nightly batch cleanup processing to delete the expired entries out of the STATUS file.

Review your nightly schedule and see which job you are running. Then determine which control member (set by the MEMBER= symbolic) is being pulled in from the CADSOPTN library for that job. Make sure that your control member has a valid PURGE date range. Typically, the "TO" date would be set to 12312059 indicating that all records in the STATUS file up until the year 2059 will be eligible for deletion if their retention has expired.