After applying Maintenance, OM Web Viewer 12.1 experienced a problem and closed.
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After applying Maintenance, OM Web Viewer 12.1 experienced a problem and closed.

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Article ID: 134709

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Updated On:

Products

Output Management Web Viewer

Issue/Introduction

This is a new install. Successfully configured, started, and logged into the server. Applied the latest cumulative maintenance. Can no longer log in. Got an error page that says the software experienced a problem and the session has closed.

Environment

  1. Output Management Web Viewer 12.1 for LInux
  2. Apache Derby
  3. Apache Tomcat®

Cause

The initial install used internal configuration instead of external.

For internal configuration, the /config, /database (when using internal Derby as the database), and other files are placed below the <Tomcat Path>/webapps/CAOMWebViewer12.

That means that when applying maintenance, all the files under the </Tomcat Path> are going to be overwritten, including the database files that were established with the original install, setup, and testing. 

Resolution

Use System Level External Configuration. In any case, now when applying new builds on top of that install that works, the configuration and database changes made before updating will be preserved.

  1. Reinstall into the /usr/local/CA_OM_Web_Viewer/...directory.
  2. Do an export command for that environment variable before running the initial configuration as:
  3. export CAOMWV12_HOME=/usr/local/CA_OM_Web_Viewer
  4. At this point set up a Started Task JCL to run the Tomcat under, but if you just want to run the startup.sh from the <Tomcat Path>/bin directory for initial testing that is fine
  5. When setting up the Tomcat JCL you would include 2 JCL Cards like:
    CAOMWV12_HOME=/u/users/omdev/apps/CA_OM_Web_Viewer_12_1_home

    export CAOMWV12_HOME="$CAOMWV12_HOME"

Additional Information

Although this article specifies OM Web Viewer for Linux, the principle applies to all platforms.