Not able to access ca business intelligence dashboard
search cancel

Not able to access ca business intelligence dashboard

book

Article ID: 134517

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Being not able to access cabi dashboard .

The display is showing "An unexpected error has occurred and the operation failed" 


Checked data source, got error as below snapshot




Environment


ca uim 9 SP1 

ca ump 9 SP1

CABI 7.1 .1


Cause

jdbc encryption was not properly done

Resolution

Correct password in \CA\SC\CA Business Intelligence\apache tomcat\webapps\jasperserver-pro\META-INF\context.xml


1 . 

Locate <name="jdbc/uim" > , replace the password with the one for <name="jdbc/jasperserver">


For instance, as for below, replace password="BBBBBBBBBB" with password="AAAAAAAAAA"



<Resource accessToUnderlyingConnectionAllowed="true" auth="Container" driverClassName="tibcosoftware.jdbc.sqlserver.SQLServerDriver" factory="com.jaspersoft.jasperserver.tomcat.jndi.JSBasicDataSourceFactory" maxActive="100" maxIdle="30" maxWait="10000" name="jdbc/jasperserver" password="AAAAAAAAAA" testOnBorrow="true" type="javax.sql.DataSource" url="jdbc:tibcosoftware:sqlserver://10.74.239.176:1433;databaseName=CA_UIM;sendTimestampEscapeAsString=false" username="sa" validationQuery="SELECT 1"/>


<!-- Comment this line to enable session persistence across Tomcat restarts -->


<Manager pathname=""/>


<Resource auth="Container" defaultTransactionIsolation="READ_UNCOMMITTED" driverClassName="tibcosoftware.jdbc.sqlserver.SQLServerDriver" factory="com.jaspersoft.jasperserver.tomcat.jndi.JSBasicDataSourceFactory" maxActive="100" maxIdle="30" maxWait="10000" name="jdbc/uim" password="BBBBBBBBBB" type="javax.sql.DataSource" url="jdbc:tibcosoftware:sqlserver://10.74.239.176:1433;databaseName=CA_UIM" username="sa"/>


</Context>


2.

Restart cabi server





Attachments