search cancel

MTCA - Error messages and can't reach URL ( 401 OK for URL: api/user )

book

Article ID: 134444

calendar_today

Updated On:

Products

OPS/MVS Event Management & Automation

Issue/Introduction

First time installation of MTCA. Had previously successfully installed and used OPSLOG web server portion.

Now when I start the tomcat server(OPSTCSRV), and I enter my credentials in the URL, I get an error message. See attached screen shot url_screenshot.png

I am also attaching the mtca-app.log file. Also attaching the OPSTCSRV job log.

If there is anything else, please let me know.

Environment

Release : 13.0 and above of OPS/MVS

Component : MAINFRAME TEAM CENTER AUTOMATION R1 and above 

Cause

Typically some sort of configuration issue, either in the system or within MTC-A

Resolution

Review the MTC-A log for WARN or ERROR messages that will indicate the potential problem.

 

if you see the below message, you should investigate the certificate problem with your security team:

 

WARN c.c.m.c.DiscoveryController - DiscoveryControllerWorker.run: Error detected initializing discovery controller. Cause = com.ca.messagingservice.api.exception.MessagingServiceException:

com.ca.messagingservice.library.brokerservice.BrokerException: Error in adding the network connector (java.io.IOException: The private key of ZMSADM.HUBCERT is not available or no authority to access the private key).