Error : 404 Page cannot be found. Please check the URL Adminui
search cancel

Error : 404 Page cannot be found. Please check the URL Adminui

book

Article ID: 134193

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On SITEMINDER

Issue/Introduction

 

When running an AdminUI and when trying to login, the browser receives
return code 404.

The AdminUI reports :

  2019-07-01 13:13:00,816 WARN [ims.default] (main) Policy Server connection enabled: false
  2019-07-01 13:12:47,964 WARN [ims.default] (main) # SiteMinder 12.52.0105.2112
  2019-07-01 13:12:47,964 WARN [ims.default] (main) ################################################
  2019-07-01 13:12:47,965 WARN [ims.default] (main) ---- CA IAM FW Startup Sequence Initiated. ----
  2019-07-01 13:12:55,006 WARN [ims.default] (main) * Startup Step 1 : Attempting to start ServiceLocator.
  2019-07-01 13:12:59,573 WARN [ims.tmt.CreateDatabaseSchema] (main) ****** Schema for: Task Persistence is up to date.
  2019-07-01 13:12:59,611 WARN [ims.tmt.CreateDatabaseSchema] (main) ****** Schema for: Archive is up to date.
  2019-07-01 13:12:59,614 WARN [ims.default] (main) * Startup Step 2 : Attempting to start PolicyServerService
  2019-07-01 13:13:00,308 WARN [ims.default] (main) Unlimited Strength Java Crypto Extensions enabled: FALSE
  2019-07-01 13:13:00,816 WARN [ims.default] (main) Policy Server connection enabled: false
  2019-07-01 13:13:00,854 WARN [ims.default] (main) * Startup Step 3 : Attempting to start ServerCommandService
  2019-07-01 13:13:02,407 WARN [ims.default] (main) * Startup Step 4 : Attempting to start EnvironmentService
  2019-07-01 13:13:02,442 WARN [ims.default] (main) * Startup Step 5 : Attempting to start SecretKeyStore
  2019-07-01 13:13:29,059 WARN [ims.default] (main) * Startup Step 6 : Attempting to start CacheManagerService
  2019-07-01 13:13:29,106 WARN [ims.default] (main) * Startup Step 7 : Attempting to load global plugins.
  2019-07-01 13:13:29,127 WARN [ims.default] (main) * Startup Step 8 : Attempting to start AdaptersConfigService
  2019-07-01 13:13:29,128 WARN [ims.jdbc.JDBCManagedObjectProvider] (Thread-14) Starting pre-population of cache for 2 object types
  2019-07-01 13:13:29,158 WARN [ims.default] (main) * Startup Step 9 : Attempting to start EmailProviderService
  2019-07-01 13:13:29,416 WARN [ims.jdbc.JDBCManagedObjectProvider] (Thread-14) Finished pre-population of cache for 2 object types
  2019-07-01 13:13:29,439 WARN [ims.default] (main) * Startup Step 10 : Attempting to start AuditProviderService
  2019-07-01 13:13:29,663 WARN [ims.default] (main) * Startup Step 11 : Attempting to start RuntimeStatusDetailService
  2019-07-01 13:13:29,771 WARN [ims.default] (main) * Startup Step 12 : Attempting to start PasswordService
  2019-07-01 13:13:29,773 WARN [ims.default] (main) * Startup Step 13 : Attempting to start LogicalAttributeService
  2019-07-01 13:13:29,785 WARN [ims.default] (main) * Startup Step 14 : Attempting to start BLTHService
  2019-07-01 13:13:29,788 WARN [ims.default] (main) * Startup Step 15 : Attempting to start ParticipantResolverService
  2019-07-01 13:13:29,790 WARN [ims.default] (main) * Startup Step 16 : Attempting to start NotificationRuleService
  2019-07-01 13:13:29,791 WARN [ims.default] (main) * Startup Step 17 : Attempting to start EventAdapterService
  2019-07-01 13:13:29,794 WARN [ims.default] (main) * Startup Step 18 : Attempting to start TaskService
  2019-07-01 13:13:29,845 WARN [ims.default] (main) * Startup Step 19 : Attempting to start WorkflowCallbackService
  2019-07-01 13:13:29,878 WARN [ims.default] (main) * Startup Step 20 : Attempting to start WorkflowService
  2019-07-01 13:13:29,933 WARN [ims.default] (main) * Startup Step 21 : Attempting to start TaskStatusNotifyService
  2019-07-01 13:13:29,948 WARN [ims.default] (main) * Startup Step 22 : Attempting to start EventService
  2019-07-01 13:13:30,148 WARN [ims.default] (main) * Startup Step 23 : Attempting to start AdminService
  2019-07-01 13:13:30,167 WARN [ims.default] (main) * Startup Step 24 : Attempting to start GeneralMonitorAdmin
  2019-07-01 13:13:30,182 WARN [ims.default] (main) * Startup Step 25 : Attempting to start GlobalInitializer plug-ins
  2019-07-01 13:13:30,262 WARN [ims.default] (main) * Startup Step 26 : Attempting to start SchedulerService
  2019-07-01 13:13:32,660 WARN [ims.default] (main) * Startup Step 27 : Attempting to start environments
  2019-07-01 13:13:32,682 WARN [ims.default] (main) ** FIPS mode enabled : false
  2019-07-01 13:13:32,813 WARN [ims.default] (main) * Startup Step 28 : Attempting to recover unprocessed events and runtime status details
  2019-07-01 13:13:32,820 WARN [ims.default] (main) * Startup Step 29 : Attempting to start ApplicationContextInitializer plug-ins
  2019-07-01 13:13:32,820 WARN [ims.default] (main) ---- CA IAM FW Startup Sequence Complete. ----

  2019-07-01 13:14:15,730 INFO [com.sun.jersey.server.impl.application.WebApplicationImpl]
  (main) Initiating Jersey application, version 'Jersey: 1.17.1 02/28/2013 12:47 PM'

  2019-07-01 13:14:30,436 INFO [org.jboss.bootstrap.microcontainer.ServerImpl]
  (main) JBoss (Microcontainer) [5.1.0.GA (build: SVNTag=JBoss_5_1_0_GA date=200905221053)] Started in 10m:29s:696ms

2019-07-01 13:22:50,624 ERROR [ims.ui] (http)
  Page cannot be found. Please check the URL. (/iam/siteminder/console/)
  
2019-07-01 14:11:27,981 ERROR [ims.ui] (http)
  Page cannot be found. Please check the URL. (/iam/siteminder/console/adminui)
  
2019-07-01 14:15:56,128 ERROR [ims.ui] (http)
  Page cannot be found. Please check the URL. (/iam/siteminder/console/)
  
2019-07-01 19:22:06,968 ERROR [ims.ui] (http)
  Page cannot be found. Please check the URL. (/iam/siteminder/console/ui7/

 

Cause

 

From the 4 last lines from the log, the browser tries to reach
different URLs :

 

  /iam/siteminder/console
  /iam/siteminder/console/adminui
  /iam/siteminder/console/ui7

 

Those aren't the default page access.

 

Resolution

 

To solve this issue :

 

  - Stop and Start the AdminUI;
  - Access the AdminUI with this URL only (use the port 8080) (1) :

    http://fqdn:8080/iam/siteminder/adminui

 

Additional Information

 

  1. Start the Administrative UI by following these steps:
    https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/siteminder/12-8/configuring/policy-server-configuration/start-the-administrative-ui-and-manage-objects.html