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Appliance disk space is filling up

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Article ID: 134177

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Updated On:

Products

CA Privileged Access Manager - Cloakware Password Authority (PA) CA Privileged Access Manager (PAM)

Issue/Introduction

Even though there is no specific change in usage, a node may start exhibiting HDD disk space problems after some time.

Cause

One possible cause may be a runaway log, for instance xcd_upd.log, which grows uncontrolled. Logs are being rotated at night by using linux's logrotate utility in the appliance. If the utility fails to rotate one or several logs, the current log will grow until filling up the disk.


This can be checked by CA Support personell logging in into the appliance and verifying the disk space in /var/log. Using as an example xcd_upd.log, one should see


xcd_upd.log

xcd_upd.log.1.gz

xcd_upd.log.2.gz

...


which basically means that the xcd_upd.log, on reaching a certain disk space and by means of logrotate, is compressed and a new xcd_upd.log is created. The number of rotated logs kept is controlled by the logrotate configuration.


If one of the logs has not been properly compressed, that has been seen to cause rotation to stop working. We would see something like


xcd_upd.log

xcd_upd.log.1

xcd_upd.log.3.gz

...


where one or several files are missing. Since logrotate is unable to rotate the files properly, the current log grows out of control until filling up too much disk space

Environment

Privileged Access Manager 3.1.X

Resolution

To solve the immediate problem, it is necessary to truncate the current log. Linux command truncate may be used to do that


truncate -s 0 /var/log/xcd_upd.log


Next it is necessary to reactivate rotation. To do so, just compress the file which was left uncompressed


gzip xcd_upd.log.1


To do both operations remote debugging access to the appliances is required. Please contact support for carrying out the operation