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Time Slice job stalls when rolling over Slice id: 194 (incident Slice)

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Article ID: 134005

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The Time slicing job is stuck and is not processing any records. In the bg-ca.log the following messages show:

INFO  2019-07-01 07:10:43,438 [Dispatch Time Slicing : [email protected] (tenant=clarity)] niku.blobcrack (clarity:admin:16697021__4E1690D0-628B-4972-9E46-4DB42DB3551F:Time Slicing) ### Processing blobcrack.modifyTeamIncidentCurve_set
INFO  2019-07-01 07:10:43,454 [Dispatch Time Slicing : [email protected] (tenant=clarity)] niku.blobcrack (clarity:admin:16697021__4E1690D0-628B-4972-9E46-4DB42DB3551F:Time Slicing) Resetting all objects to be sliced: (32) blobcrack.setAllTeamsIncidentCurveModified_set to 3

STEPS TO REPRODUCE:

  1. Set the Expiration date on slice request id: 194 to today's date
  2. Run Time Slice job

Expected Results: Job to run to completion and slice id: 194 to rollover

Actual Results: Time slice job gets stuck when trying to rollover slice id.

Cause

DE44382 & DE49753. During Incident slice rollover, the Time slice job updates all records in 'INCIDENT_SLICE_STATUS' column of the Prteam table in one statement block instead of doing so incrementally and therefore results in severe performance issues when there is a huge amount of records in the Prteam table.

Environment

Release : 15.5.1

Component : TIME SLICING

Resolution

Resolved in 15.6 and 15.8 

Workaround:

  1. Cancel and delete the Time Slice job. 
  2. Stop the Background service 
  3. Move the Expiration Date out for slice IDS 193, 194, 195 far into the future eg - the following year 
  4. Restart BG service and run Time Slice job

Additional Information

Note: If you upgrade to 15.8 you will not hit this problem.