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When clicking on a detailed timesheet for a user in New UX, the pop up incorrectly shows the user you are signed in as

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Article ID: 133797

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

When clicking on a detailed timesheet for a user in the Clarity PPM New User Experience (UX) the pop up window incorrectly shows the user you are signed in as temporarily. 


Steps to Reproduce:

1. Log in as a user with Timesheet approval rights in the New UX (User A in this example)

2.  In the Clarity New UX, click on Timesheets then Review & Approve

3. Click on a different user's timesheet from the list (User B in this example)

Expected Results: The name for the user in the popup window displays as User B.

Actual Results: Wrong user shows up temporarily (user you are logged in as if different then the user you are logged in as (User A instead of User B). Eventually it will switch to show the correct user name.

Cause

This is related to a performance issue where one or more queries need to be tuned.

Environment

Release : 15.4.1

Component : CA PPM SAAS TIME MANAGEMENT

Resolution

On Premise customers: Have the DBA check to see if there are any slow running queries, if so, using SQL Tuning Advisor can provide recommendations to optimize performance (including rebuilding the execution plan any slow running queries can help resolve the performance issue).


Clarity PPM SaaS Customers: Contact Broadcom Support for assistance


Note: Generating a Clarity PPM Action trace while reproducing the issue can help in determining if there are any slow running queries causing the issue (see steps to enable action trace at: https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=9353)