UMP doesn't load and when loading there are problems with the process of alarms
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UMP doesn't load and when loading there are problems with the process of alarms

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Article ID: 133740

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

In the morning hours UMP did not load and the UMP robot was restarted, which took approximately 8 minutes. 20 minutes ago the same incident occurred, when restarting only the wasp did not work, I had to restart the robot to pick it up.  ems queues also appeared yellow and were not processing any messages.

Environment

Release : 9.1.0

Component : UIM - UMP

Cause

- original cause unknown

Resolution

wasp:

Added these two lines to the wasp content.xml file:

<Resources cachingAllowed="true" cacheMaxSize="100000" />

    <JarScanner scanClassPath="false" />

See: https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=132483

set wasp nimpool timeout from 120 to 300.

Set min and max for wasp memory from 1024/13312 to 10240/13312 to minimize garbage collection

data_engine:

Set data_engine thread_count_insert from 0 to 8 (since there are 8 processors) as the data_engine was backed up ~1.4M messages

Set data_engine hub_bulk_size down to 1750 from 7000. It should not be set to anything higher than that for best performance.

Recommendation: if possible locate the backend UIM database on the same subnet as the Primary hub as I noticed some latency during the connection test for the data_engine.

ems:

Redeployed ems probe since the hub Queue Status windows showed all of the ems queues were yellow and not processing any messages. After redeployment, all queues were green and processing messages.