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Error occurred while opening project in MSP

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Article ID: 133414

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When attempting to export a project to MSP, MSP stops responding, and eventually times out.

The user sees one or both of the below

  • "An error occurred while opening CA PPM project in Microsoft Project. Please try again."
  • The user is continuously prompted to log in, but their login credentials are not accepted. 

Cause

There is an issue with the user's profile

In Registry Editor - If the paths in the data columns have a reference to either a directory that does not exist or a directory that the user does not have access to, this issue where the MSP Interface appears to be blocked will occur

Environment

Release : All Supported Releases

Component : CA PPM MICROSOFT PROJECT (MSP)

Resolution

  1. On your local MSP setup, find your MSP log and tmp directory. 
  2. By default, it is- 
    • C:\Users\<user>\Documents\logs
    • C:\Users\<user>\Documents\tmp
    • This is only default, this may be a little different from your path
  3. Make note of the path
  4. Open Registry Editor
  5. Go to HKEY_CURRENT_USER\Software\Niku\MSPInterface
  6. Make note of the logDirectory and tmpDirectory path
  7. Compare to your local MSP log and tmp path

If they are different, there are two options

  1. Rebuild User's Profile
  2. Manually update the logDirectory and tmpDirectory to a valid path