Authentication takes long time to logon when using LDAP and AD
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Authentication takes long time to logon when using LDAP and AD

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Article ID: 133364

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Updated On:

Products

CA Advanced Authentication - Strong Authentication (AuthMinder / WebFort) CA Strong Authentication CA Risk Authentication CA Advanced Authentication

Issue/Introduction

When using LDAP or Active Directory (AD) user store the retrieval of the user from such a store may show slowness.

Environment

Release : 9.xx (Applicable to all the supported releases)

Component : CA Advanced Authentication (Strong Authentication and Risk Authentication)

Cause

Broadcom Advanced Authentication supports user stores such as  Active Directory (AD) /  Lightweight Directory Access Protocol (LDAP).  Due to referral chasing loss of performance may occur during authentication. 

Resolution

Add a parameter to prevent referral chasing below in arcotcommon.ini (use the format in the highlighted text below) :

[arcot/extn] 

LDAP_REFFERAL_IGNORE_FLAG=ignore 

Restart the CA Strong /Risk Authentication servers running UDS application for these parameters to take effect.

Additional Information

None.