ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

MSP Save Issues - Some team and assignments don't save back to Clarity

book

Article ID: 133330

calendar_today

Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

Team members and assignments don't save back for one project from Microsoft Project (MSP) to Clarity even though the project says "Save Successful". Sometimes one or two team members save to Clarity with their assignments, but all other team members are missing, even though their initials matched their Resource ID in Clarity. 

 

Environment

Component : CA PPM MICROSOFT PROJECT (MSP)

Resolution

Delete the Text3 data from the Resource Usage view. Important: Deleting this data will delete the role ID for this field. (See: Where is the Task Assignment Role ID Defined in MSP?)

If the Text3 data is not editable/able to be deleted, here are the steps to fix the issue (Note, it's recommended to test this out in non production for any impact first to data such as dependencies, or create a backup copy of the mpp):

    1. Open the project in MSP
    2. Click File->Save As->Browse
    3. For Save as type, change this to XML Format and click Save (This saves a XML copy of the project).
    4. In MSP, click File->Open, and then Browse
    5. Change the drop down at the bottom that defaults to Projects to XML Format
    6. Browse for the XML file saved in step 3 and click Open
    7. An Import Wizard menu appears, you can leave the defaults and click Finish
    8. When the MPP file opens, go to View->Resource Usage
    9. Add the Text 3 column, and delete all Text 3 data here
    10. Now, save the project back to Clarity, this saves all resources and assignments correctly. 

Additional Information