Spectrum Report Manager (SRM) not finished starting
search cancel

Spectrum Report Manager (SRM) not finished starting

book

Article ID: 133257

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Spectrum Report Manager (SRM) not finished starting. The following error is seen in the $SPECROOT/tomcat/logs/stdout.log (Windows) or catalna.out (Linux):

ERROR 1146 (42S02) at line 21 in file: '/opt/spectrum/Install-Tools/rpmgr/sql/srmdbapi/ddl/create_v_dim_device_module.sql': Table 'reporting.devicemodule' doesn't exist

Environment

Release: 10.2.0 and above
Component: Spectrum Report Manager (SRM)

Cause

The devicemodule table in the reporting database is missing or corrupt.

Resolution

NOTE: Starting from DX NetOps Spectrum 21.2.4, the default root password for MySql is "MySqlR00t". For DX NetOps Spectrum versions prior to 21.2.4, the default root password is "root". In the following MySql commands, replace <PASSWD> with the root password for your DX NetOps Spectrum version.

Rebuild the devicemodule table in the reporting database on the SRM system.

The first step is to find out how the devicemodule table is built. Do the following on an SRM system that has the same Spectrum version and patch level installed:

1. Log into the SRM system as the user that owns the Spectrum installation

2. Stop the Spectrum Tomcat service

3. If on Windows, start a bash shell by running "bash -login"

4. cd to the $SPECROOT/mysql/bin directory and enter the following command to log into mysql:

./mysql --defaults-file=../my-spectrum.cnf -uroot -p<PASSWD> reporting 

5. Enter the following command at the mysql prompt to find out how the devicemodule table in the reporting database is built:

./show create table devicemodule;

6. The following is an example of the output from the above command:

| devicemodule | CREATE TABLE `devicemodule` (

  `module_id` int(10) unsigned NOT NULL AUTO_INCREMENT,

  `model_key` int(10) unsigned DEFAULT NULL,

  `module_index` int(10) DEFAULT NULL,

  `module_name` varchar(255) DEFAULT NULL,

  `serial_nbr` varchar(255) DEFAULT NULL,

  `software_rev` varchar(255) DEFAULT NULL,

  PRIMARY KEY (`module_id`),

  KEY `key_idx` (`model_key`,`module_index`)

) ENGINE=InnoDB DEFAULT CHARSET=utf8 |

 

The next step is to recreate the table on the SRM system where the issue is seen:

1. Log into the SRM system as the user that owns the Spectrum installation

2. Stop the Spectrum Tomcat service

3. If on Windows, start a bash shell by running "bash -login"

4. cd to the $SPECROOT/mysql/bin directory and enter the following command to log into mysql:

./mysql --defaults-file=../my-spectrum.cnf -uroot -p<PASSWD> reporting

5. Enter the following command at the mysql prompt to drop the current devicemodule table in the reporting database:

drop table devicemodule;

6. Enter the following command at the mysql prompt to rebuild the table based on the information from the other system. The following is an example:

CREATE TABLE `devicemodule` (`module_id` int(10) unsigned NOT NULL AUTO_INCREMENT, `model_key` int(10) unsigned DEFAULT NULL, `module_index` int(10) DEFAULT NULL, `module_name` varchar(255) DEFAULT NULL, `serial_nbr` varchar(255) DEFAULT NULL, `software_rev` varchar(255) DEFAULT NULL, PRIMARY KEY (`module_id`), KEY `key_idx` (`model_key`,`module_index`)) ENGINE=InnoDB DEFAULT CHARSET=utf8;

7. Enter the following command at the mysql prompt to ensure the table has been created:

show create table devicemodule;

8. If there are no errors in the creation of the devicemodule table, exist mysql by entering "quit" at the mysql prompt

9. Start Spectrum Tomcat and review the stdout.log (Windows) or catalina.out (Linux) file for the error.