PAMSC(WG) r14.0 : performance problem via accessing Endpoint Management
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PAMSC(WG) r14.0 : performance problem via accessing Endpoint Management

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Article ID: 133237

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Updated On:

Products

CA Privileged Access Manager - Server Control (PAMSC) CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

 The performance problem was reported to happen in the following environment.

 1. Endpoint Server 

    Windows 2016 / PAMSC r14.1 

2. Endpoint Management Server
   Windows 2016 / PAMSC r14.0  

When customer access 1. Endpoint Server via Endpoint Management, it takes 30 sec at each operation. 

 And also, he access to PMD on 1. Endpoint Server, it takes 10+ minites. 

But he can access rule via selang on 1. Endpoint Server itself with no delay.


What does it have the problem?


Environment

Release : 14.0

Component : PAM SERVER COMPONENTS (WEB INTERFACE/JBOSS)

Cause

When hostname is appeared in hosts file in each side, the problem is solved. 

So, the problem is caused by taking time to find host name from IP address in DNS since This environment had no reverse name resolution zone in DNS server.

Resolution

 it solved by taking action one of following configuration change.

 - Added both host entry in hosts file on each server.

 - Create reverse resolution zone on DNS server.

Additional Information

N/A