Can't see timesheet note icon in Clarity New UX when populating task from prior timesheet
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Can't see timesheet note icon in Clarity New UX when populating task from prior timesheet

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Article ID: 133068

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

New User Experience (UX) Timesheet Notes Icon Task Line Items not showing when timesheet populates with many tasks.


Steps to Reproduce:


1. In the New UX , find two consecutive periods where timesheets have not been created

2. Create a timesheet for the first time period and add at least 29 tasks

3. Configure your settings to populate from previous period

4. In New UX, go to the second time period to create that timesheet

- Populate with previous tasks

5. Note that all the tasks populate

6. Edit the first task on the timesheet to add a note


Expected Result: Note Icon Appears

Actual Result: Note Icon does not show


Notes: 

  • Once you post the timesheet, if the number of tasks reduces the icon then does appear.
  • If you initially populate with only a few tasks and then add more tasks the issue does not occur.
  • If you remove tasks once the issue occurs, the tasks with the issue remain with the issue. However, if you add a task back and enter a note on it the icon does show.

Environment

Release : 15.5.1, 15.6

Cause

This issue is caused by DE49389. This happens when you populate tasks from previous timesheet and that timesheet has 29 or more tasks on it.

Resolution

This issue is tentatively planned to be fixed in Clarity PPM 15.7 and is also fixed in 15.6.1.1 and higher. 


Workarounds: 

Option 1: Add notes to the top Notes section of the timesheet (button next to the Submit/Approve button)

Option 2: Remove any task you want to add a note to from the timesheet, then readd  the task to the timesheet. Then, when you add a note the note icon will display

Option 3: Use the + Work option to create a new timesheet, and initially only add less then 29 tasks to the timesheet. Once the timesheet is created, if you add more tasks the issue will not occur. 


Additional Information

For a similar issue that occurs when using the option of Add Assigned tasks to create a timesheet, see https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=135908