CA Log Analytics 17.3 installation issues
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CA Log Analytics 17.3 installation issues

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Article ID: 133039

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Updated On:

Products

CA App Experience Analytics

Issue/Introduction

When installing an AXA cluster, there are nodes where ElasticSearch, Kafka and Zookeeper are installed.

The Zookeeper nodes stay up but the Kafka nodes shut down on every machine.

Kafka logs will show that they timeout not being able to connect to the Zookeeper servers.

You may observe communication errors in zookeeper logs where communication over ports 2888 and 3888 are not possible.


Environment

Release : 17.3

Component : AXA LOG ANALYTICS

Cause

Ports 2888 and 3888 were not documented as required when the associated case was raised, although it has now been added to documentation on request.

Zookeeper uses port 2888 to communicate with the leader instance

Zookeeper instances communicate over port 3888 to decide which instance should be the leader

Resolution

Make sure that TCP communication is enabled for ports 2888 and 3888 on all machines where Kafka/Zookeeper is installed.

Additional Information

https://docops.ca.com/agile-operations-analytics-base-platform/17-3/en/installing-17-3-0-and-17-3-1/single-node-installation/installation-prerequisites-single-node#InstallationPrerequisites(SingleNode)-PortReference