DEVTEST Services are down due to DB error " The total number of locks exceeds the lock table size"
search cancel

DEVTEST Services are down due to DB error " The total number of locks exceeds the lock table size"

book

Article ID: 132934

calendar_today

Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder)

Issue/Introduction

DEVTEST Services are down for every 15 mins with DB error " The total number of locks exceeds the lock table size" in registry logs.  The Registry service uses MySQL DB for reporting. 

Environment

Release : All supported environments

Component : CA Application Test

Cause

MySQL runs out of locks, which for an InnoDB database occurs when the buffer pool is full

Resolution

This is not a DEVTEST issue.  

You can fix this by increasing the size of the buffer pool in your MySQL database , by editng the innodb_buffer_pool_size option in my.cnf (my.ini), to set innodb_buffer_pool_size to a number higher than the default (which is typically 8M); for instance:

for example

innodb_buffer_pool_size = 256M or higher..

Then, restart MySQL,