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Error when adding an AD user group to a user in the Identity Portal

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Article ID: 132826

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

When trying to add or remove an Active Directory group via the CA Identity Portal using an Active Directory (AD) endpoint, the access request fails if the name of the group exceeds 255 Characters.

The portal displays an error similar to the one below:

bug String or binary data would be truncated.

bug JTA transaction unexpectedly rolled back (maybe due to a timeout); nested exception is javax.transaction.RollbackException: ARJUNA016053: Could not commit transaction.

bug could not execute statement

bug ARJUNA016053: Could not commit transaction.

bug org.hibernate.exception.DataException: could not execute statement 

Cause

This is a limitation of the Identity portal database schema.

Environment

IdentityMinder(Identity Manager) 14.1

Resolution

It is the CA Identity Manager (IM) Engineering teams policy to avoid making database schema change fixes in hot fixes or cumulative patches, therefore a "proper" fix will be available in next IP release.  

In the meantime we can give you a workaround to increase the column length in the sigma database. The IP table is called 'request_account'. you can use the sql ALTER command to increase the 'request_account' table column length.

MS SQL Server database example :

ALTER TABLE request_account alter column entitlement_name nvarchar(1024);

ALTER TABLE request_account alter column entitlement_id nvarchar(1024);

Please make sure that you backup the Database before making any changes.