Unable to process Modify Task getting error "Login ID is a duplicate. Please rename"
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Unable to process Modify Task getting error "Login ID is a duplicate. Please rename"

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Article ID: 132822

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

The error happens when performing a modify user through the web UI or the Bulk Loader Client.

The scenario is that the login ID is changed from lower case to upper case or vice versa or a mix (same name but with lower and upper case characters).


The error is:

"Login ID is a duplicate. Please rename"

Environment

Release : 14.1, 14.2, 14.3, 14.4

Component : IdentityMinder(Identity Manager)

Cause

The directory attribute of login ID is case insensitive and does not differentiate between lower and upper cases.

The validation BLTH that is checking the new login ID does not allow the changing of the case for the same string in login ID. So for the BLTH 'au885' and 'Au885' and 'AU885' are the same login ID name and it will not allow it.

Resolution

The user store directory attribute of login ID is case insensitive and so does not differentiate between upper and lower case characters. The validation BLTH does not allow (by design) to change the login ID from upper to lower or vice versa or a mix. It states the login ID already exists.