"Cannot find string for id: xxxx in shared memory" in stdlog
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"Cannot find string for id: xxxx in shared memory" in stdlog

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Article ID: 13266

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Sometimes after Service Desk Manager upgrade or patch installation or customization, administrators could see repeated message like this in stdlog:

SIGNIFICANT i18nMsg.c 324 Cannot find string for id: xxxx in shared memory. Falling back to pdm.dll/message catalog

where xxxx is an integer id number and with various values

Environment

Release:  11.x and above

Cause

This message means SDM has corrupted shared memory files

Resolution

For performance reason, SDM uses shared memory files in SDM-install-root\site\shm folder and if these files are out of sync due to some new pdm.dll or message catalog, SDM will generate this kind of messages in stdlog.

In order to fix these messages, follow these steps

  1. Shutdown SDM

  2. On the server where these messages are seen, move all files in SDM-install-root\site\shm to other location so now SDM-install-root\site\shm is empty

  3. Start SDM

  4. Check stdlog to make sure those messages don't show up anymore

Additional Information

If after these steps, those messages still show, then you would need to

  1. shutdown SDM
  2. empty SDM-install-root\site\shm
  3. reboot the server
  4. start SDM
  5. check stdlog