DevTest 10.5.0 - Unable to connect to Identity and Access manager. Please check with your administrator.
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Article ID: 132620
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Updated On:
Products
CA Application Test
CA Continuous Application Insight (PathFinder)
Issue/Introduction
Getting the below error while connecting to the EnterpriseDashboardService.
Unable to connect to Identity and Access manager. Please check with your administrator.
IAM is up and working.
Environment
Release:
Component: ITKOTF
Cause
Notice a missing / in the iam.server.url property in the lisa.properties file.
Was iam.server.url=https:/machine:51111/auth
Enterprise Dashboard log shows:
2019-05-23 05:18:46,226Z (00:18) [qtp1937107943-21] WARN org.eclipse.jetty.servlet.ServletHandler - /api/login
java.lang.NullPointerException: Cannot invoke method equalsIgnoreCase() on null object
In the dradis.properties file there was a space before one of the closing parens:
dradis.db.url=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=machine.broadcom.com)(port=1530))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=machine_itko_broadcom.com )))
Resolution
Update in lisa.properties file:
iam.server.url=https://machine:51111/auth
Updated the property value of dradis.db.url to be:
dradis.db.url=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=machine.broadcom.com)(port=1530))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=machine_itko_broadcom.com)))
Restarted the Enterprise Dashboard service and was then able to log in.
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