Execution of ExploreAndCorrelateEvent failed
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Execution of ExploreAndCorrelateEvent failed

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Article ID: 132568

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

Explore and Correlate (E&C) Fails with the following error in the server log:

Execution of ExploreAndCorrelateEvent failed

2019-05-22 18:37:32,253 ERROR [ims.tmt.events] (Thread-12169) Error during event execution [e0956315-0a000110-7966aadd-d06d25ac] ExploreAndCorrelateEvent

2019-05-22 18:37:32,295 WARN  [ims.tmt.eventlistener] (Thread-419 (HornetQ-client-global-threads-952374057)) Evt IMTaskEvent:e2c951bf-b27a6984-96d17f10-ca523a is invalid.

2019-05-22 18:38:01,699 ERROR [im.provisioning.container] (default task-45) javax.naming.NamingException: [LDAP: error code 1 - :ETA_E_0021<RDI>, Active Directory Endpoint '<ActiveDirectory_endpoint>' search failed: Error decrypting attribute eTADSAuthPWD: attribute eTADSPortNum has been modified since this attribute was encrypted.  Please reset the encrypted attribute. ]; remaining name 'eTADSDirectoryName=<ActiveDirectory_endpoint>,eTNamespaceName=ActiveDirectory,dc=im,dc=eta'

 

Environment

CA Identity Manager 14.x

Cause

The Active Directory Endpoint has been switched from SSL to Non-SSL or vice versa

Resolution

To address this issue reset the ADS Endpoint ID's password.

[From etautil]

Please run the following etautil command to re-enter the password used by the ID that acquired the ADS endpoint (or re-enter the password via the UI). The USER/PWD would be the credentials used to log into the Provisioning Manager and Password would be the password used by the ID that acquired the ADS endpoint.

etautil -u <imps user> -p <imps user password> update 'eTNamespaceName=ActiveDirectory' eTADSDirectory eTADSDirectoryName='<ads endpoint>' eTADSAuthPwd='<password>' 

For Example

etautil -u etaadmin -p <etaadmin_password> update 'eTNamespaceName=ActiveDirectory' eTADSDirectory eTADSDirectoryName='<ActiveDirectory_endpoint>' eTADSAuthPwd='MyP@ssword!"' 
 

Or

[From Provisioning Manager]

On the AD Endpoint in Provisioning Manager
In Prov Manager, search for AD Endpoint,
On the ADS Server tab click Update next to the User ID,
re-enter password,
and on the Security tab make sure you have either SASL or SSL
click apply,
 
and then restart the C++ Connector Server
 

 

Additional Information

For more information on Password Management please refer to the product documentation.